Delphi Talk, Voice, and SMS Interaction Degradation

Incident Report for Delphi

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 15:00 PDT

Update

We have implemented a fix and are continuously monitoring the issue.
Posted Jun 17, 2025 - 14:11 PDT

Investigating

We are investigating degraded performance on interaction linked to an upstream provider.
Posted Jun 17, 2025 - 13:48 PDT
This incident affected: Chat Interactions, Video Calling, and Voice Calling.