Mulit-Language Voice Calling Outage

Incident Report for Delphi

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 19:45 PDT

Identified

We’ve identified an issue with one of our transcription providers that’s causing voice calls in specific non-English languages to fail. English calls are working normally, and we’re actively working on a fix.
Posted Jul 02, 2025 - 18:44 PDT
This incident affected: Voice Calling.