New user Onboarding Facing Issues

Incident Report for Delphi

Resolved

Our third party provider had an outage. We have resolved it with a work around.
Posted Jul 03, 2025 - 18:19 PDT

Investigating

New user onboarding is having issues, we are investigating the outage and will provide updates as soon as possible.
Posted Jul 03, 2025 - 14:03 PDT
This incident affected: Delphi Studio (Onboarding).