Elevated voice call failures affecting new customers

Incident Report for Delphi

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:22 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 08, 2025 - 16:58 PDT

Identified

We have identified the issue and are rolling out a fix
Posted Jul 08, 2025 - 16:55 PDT
This incident affected: Voice Calling.