YouTube Processing Facing Delays

Incident Report for Delphi

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 14:17 PDT

Identified

YouTube content may take longer to process and may fail due to YouTube's servers being overwhelmed. Should be resolved within the day.
Posted Jun 25, 2025 - 23:40 PDT
This incident affected: Delphi Studio (Processing Documents).